
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20200202012502
template: 
currentrequest: /apps/pbcs.dll/article?avis=CO&date=20200201&category=ENTERTAINMENTLIFE&lopenr=200209999&Ref=AR
currentrequestunmodified: /entertainmentlife/20200201/we-love-80s-best-of-fantastic-musical-decade
@templatetype: /apps/pbcs.dll/article?avis=CO&date=20200201&category=ENTERTAINMENTLIFE&lopenr=200209999&Ref=AR
@pagetype: article
app version: 2.0.406
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="BC Democrat Online - Las Animas, CO" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<title> We love the &#39;80s: The best of a fantastic musical decade - Entertainment & Life - BC Democrat Online - Las Animas, CO - La Junta, CO</title>
<!-- Meta Tags - Global Article6 guid: 9D3E0522-D5DE-6F83-E053-0100007F837F-->
<meta name="description" content="Not only is he the celebrated bassist and background vocalist with The Martini Shot, Pueblo's favorite dance band, and a longtime musical educator, currently at The Arts Academy at Pueblo County, Brook Mead's most impressive credential is that of being a &quot;music nerd.&quot; And that's coming from a fellow nerd. Countless times, Brook and I have discussed the gorgeous complexity of the bass line in &quot;Do Ya Think I'm Sexy,&quot; the fact that Duran Duran is essentially a funk band, the futuristic genius of" />
<meta property="bt:pubDate" content="20200201T17:00:00Z">
<meta property="bt:modDate" content="20200130T19:47:00Z">
<meta property="bt:author" content="Jon Pompia The Pueblo Chieftain">
<meta name="twitter:title" content="We love the '80s: The best of a fantastic musical decade">
<meta name="twitter:description" content="Not only is he the celebrated bassist and background vocalist with The Martini Shot, Pueblo's favorite dance band, and a longtime musical educator, currently at The Arts Academy at Pueblo County, Brook Mead's most impressive credential is that of being a &quot;music nerd.&quot; And that's coming from a fellow nerd. Countless times, Brook and I have discussed the gorgeous complexity of the bass line in &quot;Do Ya Think I'm Sexy,&quot; the fact that Duran Duran is essentially a funk band, the futuristic genius of">
<meta property="og:title" content="We love the '80s: The best of a fantastic musical decade"/>
<meta property="og:description" content="Not only is he the celebrated bassist and background vocalist with The Martini Shot, Pueblo's favorite dance band, and a longtime musical educator," />
<meta name="author" content="Jon Pompia The Pueblo Chieftain">
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:image" content="https://www.bcdemocratonline.com/storyimage/CO/20200201/ENTERTAINMENTLIFE/200209999/AR/0/AR-200209999.jpg&MaxW=1200&MaxH=630">
	<meta property="og:image" content="https://www.bcdemocratonline.com/storyimage/CO/20200201/ENTERTAINMENTLIFE/200209999/AR/0/AR-200209999.jpg">
	<meta property="og:image:width" content="3000">
	<meta property="og:image:height" content="2000">
	<meta property="vf:unique_id" content="siteCO-pub250-9D3E0522-D5DE-6F83-E053-0100007F837F">
	<link rel="canonical" href="https://www.bcdemocratonline.com/entertainmentlife/20200201/we-love-80s-best-of-fantastic-musical-decade"/>
<link rel="amphtml" href="https://www.bcdemocratonline.com/entertainmentlife/20200201/we-love-80s-best-of-fantastic-musical-decade?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.bcdemocratonline.com/entertainmentlife/20200201/we-love-80s-best-of-fantastic-musical-decade"
	},
    "headline": "We love the 80s: The best of a fantastic musical decade",
    "image": {
       "@type": "ImageObject",
       	"url":"https://www.bcdemocratonline.com/storyimage/CO/20200201/ENTERTAINMENTLIFE/200209999/AR/0/AR-200209999.jpg",
       	"height": 2000,
       	"width": 3000
    },
    "url": "https://www.bcdemocratonline.com/article/20200201/ENTERTAINMENTLIFE/200209999",
    "thumbnailUrl": "https://www.bcdemocratonline.com/apps/pbcsi.dll/bilde?Site=CO&Date=20200201&Category=ENTERTAINMENTLIFE&ArtNo=200209999&Ref=AR",
    "dateCreated": "20200202T00:00:00Z",
    "datePublished": "20200202T00:00:00Z",
    "dateModified": "20200131T02:47:00Z",
    "author": [{"@type":"Person","name":"Jon Pompia The Pueblo Chieftain"}],
    "creator": "Jon Pompia The Pueblo Chieftain",
    "publisher": {
       "@type": "Organization",
       "name": "BC Democrat Online - Las Animas, CO",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.bcdemocratonline.com/Global/images/head/nameplate/bentcountydemocrat_logo.png"
       }
    },
    "articleSection": "Entertainment & Life",
    "keywords": [""],
    "isAccessibleForFree": "False",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	},
	"isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name" : "Bent County Democrat",
    "productID": "bcdemocratonline.com:standard"
	}
  }
</script>
<meta property="fb:app_id" content="165844160153827"/>
<meta property="og:type" content="article"/>
<meta property="article:opinion" content="false"/>
<script>
window.ia = window.ia || function ()
{ (window.ia.q = window.ia.q || []).push(arguments); }
;
ia('track', 'PAGE_VIEW');
</script>
<script src="https://pymx5.com/scripts/ready.js"></script>
<script src='https://pymx5.com/scripts/ims.js'></script>
<script src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>
<script>
docReady(function()
{ ims.startServices(); }
);
</script>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.406/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
	article.summary .inner .related li {max-height:fit-content!important;}
    /*==== ARTICLE ======*/
		/*==== for taboola ======*/
    	.article-newsletter-signup{
	    	display: none;
    	}
    	@media only screen and (min-width: 768px) {
			#interstitial{display:none;}
		}
		#header-main-center{
			display: none;
		}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<script async='async' src='//cdn.adsafeprotected.com/iasPET.1.js'></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gannett-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

		
	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		          
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
			
					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.bcdemocratonline.com/news" target="_top">News</a></li><li><a href="https://www.bcdemocratonline.com/sports" target="_top">Sports</a></li><li><a href="https://www.bcdemocratonline.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.bcdemocratonline.com/lifestyle" target="_top">Life</a></li><li><a href="https://www.bcdemocratonline.com/obituaries" target="_top">Obituaries</a></li><li><a href="https://www.bcdemocratonline.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.bcdemocratonline.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.bcdemocratonline.com/homes" target="_top">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/Colaj" target="_top">Classifieds</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.bcdemocratonline.com/subscribe?g2i_source=bcdemocratonline.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<script type="text/javascript">
	function searchArchive(archval){
		if(archval == 'archive'){
			document.location.href = 'http://nl.newsbank.com/nl-search/we/Archives?p_product=BCDB&p_theme=gatehouse&p_action=keyword';
		}else{
			return false;
		}
	}
</script>
<div class="input-group-btn">
	<button type="button" class="btn btn-default dropdown-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="caret"></span></button>
	<ul class="dropdown-menu" id="searchparam_dd">
		<li data-type="site" class="selected">Site</li>
<li data-type="archive">Archive</li>
	</ul>
</div><!-- /btn-group -->
<script>
$(document).on('click', '#searchparam_dd li', function() {
	searchArchive($(this).data('type'));
});
</script>
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.bcdemocratonline.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
			<style>@media screen and (max-width:479px){#header-main #toprail-nav-left{-webkit-box-flex:0;-moz-box-flex:0;box-flex:0;-webkit-flex:0;-moz-flex:0;-ms-flex:0;flex:0;}}</style>
		<div id="toprail-microbar">
			<div class="ad text-center">
				<div class="ad ad-topbanner text-center" data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Micro Bar","sov":"base ROS","allow_adx":"false"}' id="topBarSponsor" data-dimensions="[88,31]"></div>
			</div>
		</div>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.bcdemocratonline.com">
							<img class="mainheadnameplate" src="https://www.bcdemocratonline.com/Global/images/head/nameplate/bentcountydemocrat_logo.png"  alt="BC Democrat Online - Las Animas, CO" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.bcdemocratonline.com/subscribe?g2i_source=bcdemocratonline.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.bcdemocratonline.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.bcdemocratonline.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>

				<div class="ad ad-billboard text-center" id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20200130194734">
	<div class="inner">
		<h1 class="headline">We love the '80s: The best of a fantastic musical decade</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			        <figure class="thumb">
            <img class="image" src="https://www.bcdemocratonline.com/storyimage/CO/20200201/ENTERTAINMENTLIFE/200209999/AR/0/AR-200209999.jpg&MaxH=200&MaxW=200" width="100%">
            <!--div class="image-caption">
                <div class="description">For many, including Brook and yours truly, Depeche Mode is one of the greatest and most influential acts of all time, not just the '80s. [AP PHOTO/FILE]</div>
                <div class="credit"></div>
            </div-->
        </figure>
			<div class="article-body">
				<span class="byline-item">
					By Jon Pompia The Pueblo Chieftain
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Saturday</h3>
							<span class="article-meta-date">Feb&nbsp;1,&nbsp;2020&nbsp;at&nbsp;5:00&nbsp;PM</span>
							<span class="article-meta-updated"></span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p><p>Not only is he the celebrated bassist and background vocalist with The Martini Shot, Pueblo's favorite dance band, and a longtime musical educator, currently at The Arts Academy at Pueblo County, Brook Mead's most impressive credential is that of being a "music nerd."</p><p>And that's coming from a fellow nerd.</p><p>Countless times, Brook and I have discussed the gorgeous complexity of the bass line in "Do Ya Think I'm Sexy," the fact that Duran Duran is essentially a funk band, the futuristic genius of DEVO, and similar important issues.</p><p>And like yours truly, Brook is a child of the '80s, arguably the greatest and most eclectic era of all.</p><p>So here, in order, are my kindred soul's choices for the top 10 from that majestic period:</p><p>"Everybody Wants to Rule the World," Tears For Fears. This song is a quintessential '80s hit. Beautifully crafted from a two chord riff, the incessant drum part and the synthesizer progression set the tone for the strong lyrical content. &#x201c;Welcome to your life, there&#x2019;s no turning back.&#x201d;</p><p>Jon: The natural choice to top any list worth its salt, this is, in many ways, one of the greatest songs ever written and recorded. There's no need to rehash my love for Tears for Fears, and since this appeared on my previous lists, I'll instead propose another standout from the 1985 album that produced this gem, the often overlooked "Mother's Talk," fueled by one of the most potent basslines of all time.</p><p>"In Your Eyes," Peter Gabriel. One of the most beautiful songs about love and devotion. The African rhythms and the solo by Senegalese singer Youssou N&#x2019;Dour give it an eclectic world feel, and who can forget John Cusack in the rain, holding a boom box as it played this song, in the movie "Say Anything?" All in all, it is the epitome of Peter&#x2019;s work in the '80s.</p><p>Jon: Following the art rock pretentiousness of Genesis, Gabriel became a bonafide pop star, thanks to "Sledgehammer," "Big Time," "Shock the Monkey" and my personal favorite, "Games Without Frontiers." For me, it's that quirky number that defines Gabriel's genius. But an '80s list without the Psychedelic Furs is woefully incomplete, so I'm putting the indispensable "Love My Way," from 1982, here.</p><p>"I Melt with You," Modern English. This song is an excellent cross sample of the English contributions to New Wave. Every time I hear it, I&#x2019;m transported back to high school. The synth line and the simple progression is haunting yet comforting as well. It is also lyrically poetic. &#x201c;Moving forward using all my breath, making love to you was never second best.&#x201d;</p><p>Jon: The quintessential '80s song if there ever was one, "Melt" has been part of my all time set list since its release in 1982. It's tragic that Modern English never again reached such lofty heights, but the timelessness of this single ensures this British act's place in the annals of music history. To avoid duplicity, however, I'm placing the magical, but criminally under-heralded, "One Simple Thing," a 1986 track by The Stabilizers, in this spot. Track it down, and you can thank me later.</p><p>"If You Were Here," Thompson Twins. I wasn&#x2019;t much of a fan of them in the '80s, but something about that song makes me want to include it here. It has a very dissonant synth line that pitch bends into tune at the beginning. Then, the progression starts, and the lyrics are beyond excellent. It was the perfect choice for the end of the movie "Sixteen Candles" as well. I always thought it was such a different composition from all others of its time and it still holds up today.</p><p>Jon: Contrarily, I'm a massive fan of Thompson Twins, dating back to the days of "Lies" and "Love on Your Side." And I thought I was the only one aware of this hidden gem, which appeared on the Twins' 1983 album "Quick Step and Side Kick" but only became known thanks to its appearance in the beloved Molly Ringwald motion picture. A deep cut for sure, but be sure not to overlook other classic pieces like "Hold Me Now," "Lay Your Hands on Me" and "Doctor Doctor."</p><p>"Life&#x2019;s What You Make It," Talk Talk. I know the obvious choice from Talk Talk is "It&#x2019;s My Life," but I always liked how the piano doubled the bass line on this song. Being that I am a bassist by trade, I always dig the groove of the song and the wonderful quality of Mark Hollis&#x2019; voice. I know there could be better songs to represent this duo, but to this day, Talk Talk is one of my favorite bands from the '80s.</p><p>Jon: I'll second that emotion, as I believe Talk Talk is one of the most underappreciated acts that emerged during the decade. No Doubt's lone contribution to music, in my opinion, is its cover of the seminal "It's My Life," which, hopefully, introduced one of the most striking and hook-laden creations to the wider audience it deserves. But I'm with Brook on this: "Life's What You Make It," the centerpiece of the soundtrack to one of the greatest years of my life, is a masterwork of pop perfection. And it's a pity that Mark Hollis left music, and life itself, much too early.</p><p>"Pictures Of You," The Cure. The Cure are one of my favorite bands of all time. They are quirky and somewhat hard to listen to at first, but after a while you discover how musically intricate they are. 1989&#x2019;s "Disintegration" album is one of the best, and even though I know the song "Just Like Heaven" is the mainstream hit, this song reminds me of good times with friends and relationships that have long since ended.</p><p>Jon: Like Depeche Mode, The Cure defined the 80s, and for music lovers, it comes down to selecting the song that best personifies the band and one's memories of that period. Also from "Disintegration," arguably the band's most consistent disc, I'm siding with "Lullaby," a dark and ominous pop nugget driven by incessant, angular guitar chording. It's the ideal representation of songwriter Robert Smith's penchant for pairing catchy hooks with less-than-cheery topics: in this instance, being eating alive by a giant spider.</p><p>"More Than This," by Roxy Music. The smooth velvet sounds of crooner Bryan Ferry always impressed me as a vocalist. I also love the sound of this band, never afraid to have a saxophone player who doubled on oboe, ha ha. Brian Eno, the famous producer, played synthesizer with Roxy Music: a great mix of glam, disco, and New Wave, their sound was unique.</p><p>Jon: Having recently appeared on my list of greatest songs ever, I won't resubmit this 1982 romantic anthem here. What I will do, though, is divert your attention to more greatness from Ferry and Roxy Music, in the form of the thumping "Love is the Drug," the sensuous "Flesh and Blood" and the elegant "Avalon." All worthy of accolades and repeated spins.</p><p>"Don&#x2019;t You Forget About Me," Simple Minds. Although I am partial to their song "Alive and Kicking," this song was a staple of the '80s. Grounded by a stellar drum performance and stabbing keyboard lines, this song became a mantra for teenagers everywhere, especially when it was used at the end of the movie "The Breakfast Club." I know it is a cheesy pick, but no other song in this list reminds me of the '80s more than this one.</p><p>Jon: A staple of the '80s that now has veered into the realm of "entirely overplayed." Not even a Simple Minds' original, this 1984 soundtrack inclusion did make superstars, at least for a spell, of these Scottish performers. And that was not a bad thing, as Jim Kerr and cohorts went on to release a host of quality records, including "All the Things She Said" and "Sanctify Yourself." But I'm placing the wonderful "Forever Live and Die," from OMD, in this spot. OMD was, of course, the synth-pop duo responsible for "If You Leave," a soundtrack highlight of another essential '80s movie, "Pretty in Pink."</p><p>"Just Can&#x2019;t Get Enough," Depeche Mode. One of the most influential bands for me. I couldn&#x2019;t get over the amazing contrapuntal synth parts when I was teenager. It is simple pop, yet it is very polyphonic in texture, with all of the different synth parts entwining throughout. It made me want to play synthesizer with a vengeance, and to this day, I consider it a synth pop masterpiece. It has been resurfacing in commercials here and there, which cracks me up now. Any song by Depeche Mode could be inserted here for me.</p><p>Jon: This is the first song that introduced me to the band that remained on constant rotation for most of the '80s and '90s, and like Brook, demanded that I purchase an electronic keyboard to work out that inescapable opening riff. But my heart lies with Depeche's darker and more gothic output, a result of Martin Gore assuming songwriting duties from the departed Vince Clarke. From 1987's "Music for the Masses," "Never Let Me Down" is my essential DM track.</p><p>"Save a Prayer," Duran Duran. I learned how to sing harmonies, with my friends back in high school, to this song. The synth arpeggio that Nick Rhodes plays starts the song off kind of like it is in a cloud of ether, then the drums and bass kick in with a serpentine lead synth line. Simon LeBon&#x2019;s vocals and Rhodes' harmonies are strong, and the lyrics even stronger. &#x201c;Don&#x2019;t say a prayer for me now, save it till the morning after.&#x201d; Obviously, "Hungry Like the Wolf" and "Rio" are the standouts from this decade, but something about this one always sticks with me more.</p><p>Jon: The gorgeous, unearthly ballad that kick-started my bro-mance with Duran Duran, and John Taylor especially. Brook described it better than I ever could, and I will only add that I will forever associate this with the most glorious, but all too brief, periods of my life.<br/><br/>Brook's honorable mentions: "One Thing Leads to Another" and "Stand or Fall," The Fixx; "Dear God," XTC; "It&#x2019;s the End of The World As We Know It (And I Feel Fine)," R.E.M; "Girls on Film," Duran Duran; "Ghosts," Japan; "Whip It," DEVO.</p><p>jpompia@chieftain.com</p><p>Twitter: @jpompia</p></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.bcdemocratonline.com/subscribe?g2i_source=bcdemocratonline.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
								<h2>Sign up for daily e-mails</h2>
										<form id="sfNewsletterForm_footer" class="sfNewsletterForm form-inline">
			<input type="email" name="sfUserEmail" class="sfUserEmail" placeholder="Enter Email Address">
			<input type="hidden" name="sfSource" class="sfSource" value="footer">
			<input type="submit" name="sfSignup" class="sfSignup btn btn-newsletter" value="Sign Up Now">
			<div class="sfResults">
			</div>
		</form>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://myprofile.bcdemocratonline.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTAO_BCD" target="_top">My Profile</a></li><li><a href="https://www.bcdemocratonline.com/contact" target="_top">Contact Us</a></li><li><a href="http://mediakit.gatehousemedia.com/LaJunta_CO/" target="_blank">Advertise With Us</a></li><li><a href="http://adportal.marketplaceadsonline.com/gatehouse-adportal/colaj-classified/index.html" target="_top">Place Classified Ad</a></li></ul></div><div class="footer-col"><h4>Market Place<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://www.bcdemocratonline.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.bcdemocratonline.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li></ul></div><div class="footer-col"><h4>Community Info<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.bentcounty.org/" target="_blank">Bent County</a></li></ul></div><div class="footer-col"><h4>Sports & Recreation<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.bentcounty.org/recreation-attractions/" target="_blank">Bent County Recreation</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=CO&date=20200201&category=ENTERTAINMENTLIFE&lopenr=200209999&Ref=AR -->
			<div id="footer-main-copyright">
					<p id="footer-copyrightInfo">&copy; Gannett Co., Inc. 2020. All rights reserved.</p>
	<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
	<br />BC Democrat Online - Las Animas, CO  ~ 422 Colorado Avenue, La Junta, CO 81050<span class="gdpr hide"> ~ <a id="ot-sdk-btn" class="ot-sdk-show-settings" href="javascript:void(0);">Do Not Sell My Personal Information</a> ~ <a href="https://www.bcdemocratonline.com/section/cookie-policy" target="_blank">Cookie Policy</a></span><span class="gdpr-disabled hide"> ~ <a href="https://www.gannett.com/cookie-policy/" target="_blank">Do Not Sell My Personal Information</a></span> ~ <a href="http://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gannett.com/terms-of-use/" target="_blank">Terms Of Service</a> ~ <a href="https://www.gannett.com/ccpa/" target="_blank">Your California Privacy Rights / Privacy Policy</a></p>
	<p><a href="/ownership">Gannett | USA TODAY NETWORK</a></p>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.bcdemocratonline.com/subscribe?g2i_source=bcdemocratonline.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.bcdemocratonline.com" target="_top">Home</a></li><li><a href="https://www.bcdemocratonline.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"952"><a href="https://www.bcdemocratonline.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"953"><a href="https://www.bcdemocratonline.com/news/court-news" target="_top">Court News</a></li><li id="navLink-TEST-"954"><a href="https://www.bcdemocratonline.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"956"><a href="https://www.bcdemocratonline.com/news/police-fire" target="_top">Police & Fire</a></li><li id="navLink-TEST-"958"><a href="https://www.bcdemocratonline.com/news/state-news" target="_top">State News</a></li><li id="navLink-TEST-"957"><a href="https://www.bcdemocratonline.com/news/shareable" target="_top">Shareable</a></li></ul></li><li><a href="https://www.bcdemocratonline.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"961"><a href="https://www.bcdemocratonline.com/sports/high-school" target="_top">High School</a></li></ul></li><li><a href="https://www.bcdemocratonline.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"964"><a href="https://www.bcdemocratonline.com/entertainment/books" target="_top">Books</a></li><li id="navLink-TEST-"965"><a href="https://www.bcdemocratonline.com/entertainment/celebrity-news" target="_top">Celebrity News</a></li><li id="navLink-TEST-"966"><a href="https://www.bcdemocratonline.com/entertainment/movies" target="_top">Movies</a></li><li id="navLink-TEST-"967"><a href="https://www.bcdemocratonline.com/entertainment/music" target="_top">Music</a></li><li id="navLink-TEST-"942"><a href="https://www.bcdemocratonline.com/entertainment/tv-guide" target="_top">TV Guide</a></li><li id="navLink-TEST-"38361"><a href="https://www.bcdemocratonline.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.bcdemocratonline.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52182"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li><li id="navLink-TEST-"971"><a href="https://www.bcdemocratonline.com/lifestyle/boomers" target="_top">Boomers</a></li><li id="navLink-TEST-"972"><a href="https://www.bcdemocratonline.com/lifestyle/faith" target="_top">Faith</a></li><li id="navLink-TEST-"973"><a href="https://www.bcdemocratonline.com/lifestyle/family" target="_top">Family</a></li><li id="navLink-TEST-"974"><a href="https://www.bcdemocratonline.com/lifestyle/food" target="_top">Food</a></li><li id="navLink-TEST-"975"><a href="https://www.bcdemocratonline.com/lifestyle/health" target="_top">Health</a></li><li id="navLink-TEST-"976"><a href="https://www.bcdemocratonline.com/lifestyle/home-garden" target="_top">Home & Garden</a></li><li id="navLink-TEST-"977"><a href="https://www.bcdemocratonline.com/lifestyle/pets" target="_top">Pets</a></li><li id="navLink-TEST-"978"><a href="https://www.bcdemocratonline.com/lifestyle/travel" target="_top">Travel</a></li></ul></li><li><a href="https://www.bcdemocratonline.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"981"><a href="https://www.bcdemocratonline.com/opinion/columns" target="_top">Columns</a></li><li id="navLink-TEST-"982"><a href="https://www.bcdemocratonline.com/opinion/editorials" target="_top">Editorials</a></li><li id="navLink-TEST-"983"><a href="https://www.bcdemocratonline.com/opinion/letters" target="_top">Letters</a></li></ul></li><li><a href="https://www.bcdemocratonline.com/business-news" target="_top">Business</a></li><li><a href="https://www.bcdemocratonline.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.bcdemocratonline.com/photos" target="_top">Photos</a></li><li><a href="https://www.bcdemocratonline.com/videos" target="_top">Videos</a></li><li><a href="https://www.bcdemocratonline.com/calendar" target="_top">Calendar</a></li><li><a href="https://www.bcdemocratonline.com/contests" target="_top">Contests</a></li><li><a href="https://www.bcdemocratonline.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.bcdemocratonline.com/submit" target="_top">Submit your news</a></li><li><a href="https://www.bcdemocratonline.com/section/promoted//?prx_adpz=2164" target="_top">From Our Advertisers</a></li><li><a href="https://www.bcdemocratonline.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.bcdemocratonline.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTAO_BCD" target="_top">My Profile</a></li><li><a href="https://www.bcdemocratonline.com/subscribe" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://mediakit.gatehousemedia.com/LaJunta_CO/" target="_blank">Advertise With Us</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/Colaj" target="_top">Classifieds</a></li><li><a href="https://www.bcdemocratonline.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.bcdemocratonline.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.bcdemocratonline.com/homes" target="_top">Homes</a></li><li><a href="https://www.bcdemocratonline.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li><li><a href="http://bcdemocratonline.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:bcd@ljtribune.com">Feedback</a>
		</li>
		<li>
			<a href="/ownership">Ownership</a>
		</li>
		<li>
			<a href="https://www.gannett.com/terms-of-use/" target="_blank">Terms of Use</a>
		</li>
		<li>
			<a href="https://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a>
		</li>
		<li>
			<a href="https://www.gannett.com/brands/" target="_blank">Gannett Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.bcdemocratonline.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/pages/Bent-County-Democrat/133429776731542""
								target="_blank"
								title="BC Democrat Online - Las Animas, CO Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="/section/feed"
								target="_blank"
								title="BC Democrat Online - Las Animas, CO RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.bcdemocratonline.com/contact"
								title="Contact BC Democrat Online - Las Animas, CO">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp hide">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
        <a href="http://bcdemocratonline.com/subscribenow" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.bcdemocratonline.com/apps/pbcs.dll/article?avis=CO&date=20200201&category=ENTERTAINMENTLIFE&lopenr=200209999&Ref=AR"}'>
            Learn More
        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.406/app.min.js" crossorigin="anonymous"></script>
		<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
		<script>
		function __gh__init() {
		var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
			<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2020-02-02&nbsp;12:03:52-->
	</body>
</html>
